2014 Nissan Cube - Nissan Cube Forums: Nissan Cube Enthusiast Forum
 
Go Back   Nissan Cube Forums: Nissan Cube Enthusiast Forum > General Nissan Cube Discussions > Nissan Cube Forum General Discussion

CubeForums.com is the premier Nissan Cube Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Reply
 
LinkBack Thread Tools Display Modes
Old 10-12-2018, 01:20 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2018
Posts: 1
Angry 2014 Nissan Cube

Hi all,
I have a 2014 Nissan Cube that has the check engine light on for a lean bank 1 code.
It will go out and come back on sometimes not at all but most times after 20 miles of driving.
It also stalls and and starts bucking or no start it only has 97,XXX miles on it.
The O2 sensors have been replaced already air filter clean no fuel filter on it any help would be deeply appreciated the dealer has no clue where it's being worked on. Thanks and God bless.
Robyn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-08-2019, 01:27 AM   #2 (permalink)
Junior Member
 
Join Date: Mar 2019
Posts: 6
Default

Thanks for sharing this
marthawilliam is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© CubeForums.com
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2